Cashier Maintenance - Error

Cashier Maintenance - Error

Issue
When attempting to add or update existing cashiers in Back Office, when the Update and Send to Tills button is pushed a list of error messages show including:
<Description>Violation of UNIQUE KEY constraint 'IX_POSCashiers_2'. Cannot insert duplicate key in object 'dbo.POSCashiers'.
<Description>Cannot set the code of a global cashier to the code of a local cashier

Cause
Once cashiers are created in Back Office and you click Update and Send to Tills - a batch process runs which sends that information to all tills. If individual cashiers have been created on a single till, rather than in Back Office, when this batch process runs it will fail with the above errors as it will read them as duplicates.

Solution
The key here is to never enter individual cashiers onto single tills and to only add cashiers via the above Back Office process. If however you are already in this position please raise a new ticket and paste in the error messages. 
There is also the possibility that the cashier on a till may not have fed into Stockade, if this is so you'll need to remove the cashier off the till by pressing Menu > Maintenance > Assistants > Delete.

Internal
Within Stockade, select Maintenance then Cashiers. Now right click on each non-global cashier and delete them. 
    • Related Articles

    • Create a new Cashier? Old Till System

      Adding a New Cashier Select the Cashier Maintenance program from the EPOS menu. To setup new cashier details, select ADD A NEW CASHIER. If the cashier is likely to be working in all locations, then select the default 'All' for POS Location. If they ...
    • Running the Cashier & Location Contribution Report

      The Cashier & Location Contribution Report shows by cashier, the total number of sales they made, the average value of each sale, the total value of sales (Inc and Excl of VAT), the number of voids nad refunds, along with the percentile value of the ...
    • Cashier Permissions MCR

      Load the Cashier Maintenance program: Now, click into your cashier of choice, and set the MCR Operator Group of your choice. The options are Cashier, Manager, Supervisor, Matchday Staff and Non-Till Operators: Each of these have a pre-set ...
    • Customer Order Despatch Error

      When despatching order,an error is showing: -The Specified printer name "XXXX" does not exist or is not installed in this machine. -Customer Order Despatch Error -Setting up automatic Order Despatch printing -Printer error If you're getting the above ...
    • Common Despatching Errors and how to fix them

      Box 1 - INTERSOFT FAIL: Error deserializing XML message. Check your XML complies with the API documentation If the product name contains the symbol "&" then you will experience the above error message when attempting to despatch. Go to Stock ...